爱分享
分享是一种态度

初始化mysql数据库时出现下面错误,解决方法。

[[email protected] mysql]# ./scripts/mysql_install_db --user=mysql
FATAL ERROR: please install the following Perl modules before executing ./scripts/mysql_install_db:
Data::Dumper

解决方法 :安装autoconf库,命令:yum -y install autoconf //此包安装时会安装Data:Dumper模块

[[email protected] mysql]# yum -y install autoconf
已加载插件:fastestmirror
Loading mirror speeds from cached hostfile
* base: mirror.bit.edu.cn
* extras: mirror.bit.edu.cn
* updates: mirror.bit.edu.cn
正在解决依赖关系
--> 正在检查事务
---> 软件包 autoconf.noarch.0.2.69-11.el7 将被 安装
--> 正在处理依赖关系 m4 >= 1.4.14,它被软件包 autoconf-2.69-11.el7.noarch 需要
--> 正在处理依赖关系 perl(Data::Dumper),它被软件包 autoconf-2.69-11.el7.noarch 需要
--> 正在检查事务
---> 软件包 m4.x86_64.0.1.4.16-10.el7 将被 安装
---> 软件包 perl-Data-Dumper.x86_64.0.2.145-3.el7 将被 安装
--> 解决依赖关系完成


依赖关系解决


================================================================================================================================
Package 架构 版本 源 大小
================================================================================================================================
正在安装:
autoconf noarch 2.69-11.el7 base 701 k
为依赖而安装:
m4 x86_64 1.4.16-10.el7 base 256 k
perl-Data-Dumper x86_64 2.145-3.el7 base 47 k


事务概要
================================================================================================================================
安装 1 软件包 (+2 依赖软件包)


总下载量:1.0 M
安装大小:2.8 M
Downloading packages:
(1/3): perl-Data-Dumper-2.145-3.el7.x86_64.rpm | 47 kB 00:00:00
(2/3): autoconf-2.69-11.el7.noarch.rpm | 701 kB 00:00:00
(3/3): m4-1.4.16-10.el7.x86_64.rpm | 256 kB 00:00:02
--------------------------------------------------------------------------------------------------------------------------------
总计 455 kB/s | 1.0 MB 00:00:02
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
正在安装 : m4-1.4.16-10.el7.x86_64 1/3
正在安装 : perl-Data-Dumper-2.145-3.el7.x86_64 2/3
正在安装 : autoconf-2.69-11.el7.noarch 3/3
验证中 : perl-Data-Dumper-2.145-3.el7.x86_64 1/3
验证中 : m4-1.4.16-10.el7.x86_64 2/3
验证中 : autoconf-2.69-11.el7.noarch 3/3


已安装:
autoconf.noarch 0:2.69-11.el7


作为依赖被安装:
m4.x86_64 0:1.4.16-10.el7 perl-Data-Dumper.x86_64 0:2.145-3.el

完毕!

安装完autoconf库,再运行./scripts/mysql_install_db –user=mysql,问题消失。

赞(0)
未经允许不得转载:爱分享 » 初始化mysql数据库时出现下面错误,解决方法。

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址